This project wraps the Watson Developer Cloud Java SDK ( and exposes it to an XPages extension library plugin.

The Maven configuration determines the version wrapped - in this case 4.0.0.

*Requires Domino 9.0.1 FP8+ server.The plugin has not been tested on any Domino version prior to 9.0.1 FP8. It is unsupported on prior versions, because at least some APIs in the Watson Developer Cloud Java SDK require Java 8.

XPages applications using the SDK do not need to be coded in Java 8 constructs and will be able to access the plugin to compile using Java 6. So a specific Domino Designer version is not required.

Java Policy Updates

Java security policy updates will be required. Not all Watson services have been tested, only Watson Conversation API. The minimum required to use all aspects of the plugin are:

// For Java reflection

permission java.lang.reflect.ReflectPermission "suppressAccessChecks";

permission java.lang.RuntimePermission "accessDeclaredMembers";

// For Watson Java SDK

permission java.lang.RuntimePermission "getenv.VCAP_SERVICES";

permission "getProxySelector";

Other permissions may be required. See README for more details.